The CD Pipeline issue which caused this issue has been fixed. The team is working on ways to ensure such a configuration issue doesn't happen again.
Posted Feb 17, 2026 - 15:45 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 17, 2026 - 15:28 UTC
Monitoring
Date: 17th Feb, 2026 Duration: 20:22:00 IST – 20:31:00 IST Region Affected: Mumbai
Summary
During a scheduled patch upgrade of the API Management service, the Mumbai instance was inadvertently pointed to an incorrect database instance. The target database did not contain the required collections and tables.
Although the application health checks returned a valid status, the service was effectively connected to the wrong database, resulting in 404 Route Not Found errors for API requests.
The issue was identified and reversed within 9 minutes.
Timeline
20:22:00 IST – Patch upgrade initiated; service configuration temporarily pointed to an incorrect database instance.
20:22:00 – 20:31:00 IST – API requests returned 404 errors due to missing collections/tables in the misconfigured database. Health checks continued to report the service as healthy.
20:31:00 IST – Configuration reverted to the correct database instance. Service functionality restored.
Impact
API requests routed through the Mumbai API Management instance returned 404 Route Not Found errors.
Health checks did not detect the issue as the service was operational but connected to the wrong database.
The incident duration was approximately 9 minutes.
No other regions were impacted.
Root Cause
During the patch upgrade process, the API Management service configuration was temporarily pointed to an alternate database instance that did not contain the required schema (collections and tables).
The system health checks validated service availability but did not validate database schema correctness or configuration alignment, resulting in a false-positive healthy state.
Resolution
The service configuration was reverted to the correct database instance at 20:31:00 IST.
API functionality was fully restored following the rollback.
Preventive & Corrective Actions
We are currently working on implementing a permanent resolution, including:
1. Strengthening deployment validation checks to verify database instance alignment before routing traffic. 2. Enhancing health checks to validate database schema presence in addition to service availability. 3. Introducing additional safeguards in the patch upgrade process to prevent misconfiguration during upgrades.
Current Status
The issue has been fully resolved. A permanent fix is in progress to prevent recurrence.
Posted Feb 17, 2026 - 15:25 UTC
This incident affected: India Cluster [AWS] (APIM Gateway).